Problema ao inicializar o grails
10/03/2016 03:42
0
Sou developer Java  e Android, queria usar o framework, comecei a ter curiosidade depois de ver uma palestra no youtube do kiko sobre produtividade com java para web, mas enfim vamos la. Estou com o seguinte prolema. sempre que vou iniciar o grails ele nunca roda, da a seguinte mensagem!

| Error Command [create-app] error: IOException in C:\Users\AJJB\.m2\repository\org\grails\profiles\angular\3.1.3\angular-3.1.3.jar - java.io.IOException:Failed to delete C:\Users\AJJB\.m2\repository\org\grails\profiles\angular\3.1.3\angular-3.1.3.jar while trying to rename C:\Users\AJJB\.m2\repository\org\grails\profiles\angular\3.1.3\rep5171394194536951734.tmp (Use --stacktrace to see the full trace)



Alguem pode me ajudar?
Tags: Grails,Instalação Grails, Grails nao rodando,Problemas com Grails, Ajuda instalação do Grails


0
Olá Aj,
  Já tive problema semelhante quando rodei o grails no C:, você deve estar com problema de edição nas pastas em questão.
10/03/2016 10:06


0
Oi Aj, legal ter te motivado, valeu!

Olha: este problema que você está enfrentando na realidade é o Windows bloqueando os arquivos. Sendo assim, sugiro que faça o seguinte: certifique-se de que não haja nenhum projeto Java em execução na sua máquina.
Em seguida, renomeie temporáriamente a pasta .m2 para .m3 ou qualquer outro nome.
Em seguida, execute novamente a aplicação. 
Qualquer coisa, estou aqui pra te ajudar, ok?


0
kiko e Diego vlw mesmo por tentar ajudar , mas na verdade nao sou user windows  sou ubuntu.... queria rodar tudo pelo terminar , mas a sollução ate entao que consegui foi rodar a ide deles mesmo o ggts, sendo que nela so pega o grails que ja vem nela, que no caso é o 2.4.4.. tento selecionar o grails 3.1.3 e ela nao reconhece...... mas com o 2 da pra rodar de boa, mas queria mesmo era rodar pelo terminal igual kiko tava fazendo e da forma que faço com o ruby on rails. Aguardo respostas
11/03/2016 11:11


0
Pessoal depois de tanto procurar encontrei uma solução....vou passar para quem tiver o mesmo problema resolver.Simplesmente pq a nova versão do java(8.0) nao roda perfeitamente no ubuntu nem no mac OS..... a solução é a seguinte:

primeira coisa é instalar um JDK  inferiior a versão, no meu caso tou usando java version "1.7.0_95". Use os  comandos a seguir :
sudo apt-get install default-jdk
sudo apt-get install default-jre

finalize verificando se o jova esta instalado. use o comando java -version

segundo passo a se fazer é baixar o SDKMAN (detalhe nao é o mesmo do android). use o seguinte comando.:

curl -s http://get.sdkman.io | bash

a instalação não é demorada, depois de concluido feche o terminal e abra um novo.

terceiro passo com um novo terminal aberto use o comando a seguir. 

sdk install grails

apos finalizar a instalação dos pacotes, feche novamente o terminal e crie a pasta para ser o diretorio railz do grails, para isso use o seguinte codigo.

mkdir grails

Pronto estamos quase finalizando! depois de criar a pasta raiz, entre nela para pode definir a mesma como tal. para isso utilize aquele velho comando "CD".

cd grails

para finalizar digite o codigo de criação da aplicação 

grails create-app (nome do app)   ..... em seguinda so abrir a pasta que criou por exemplo :

grails create-app teste.......... cd teste

pronto! agora so começar a programar. Cmg deu certo, espero ter ajudado.
15/03/2016 01:10



Ainda não faz parte da comunidade???

Para se registrar, clique aqui.


Aprenda Groovy e Grails com a Formação itexto!

Newsletter Semana Groovy

Assinar

Envie seu link!


Livro de Grails


/dev/All

Os melhores blogs de TI (e em português) em um único lugar!

 
Creative Commons
RSS Grails Brasil é mantido por itexto Consultoria.
Em caso de problemas contacte Henrique Lobo Weissmann (Kico) por e-mail: kico@itexto.com.br
Todo o conteúdo presente neste site adota o Creative Commons como licença padrão.
Ver: 4.14.0
itexto