Grails 3.0 e versão do JDK
16/04/2015 08:14
1
Fui instalar o grails 3.0 na minha máquina e ao rodar os comandos do grails deu erro, demorei um pouco a descobrir, o problema era a versão do meu JDK que era 1.6, olhando depois na documentação vi que o grails 3.0 necessita do JDK 1.7 ou superior.




Documentação: Before installing Grails 3.0 you will need as a minimum a Java Development Kit (JDK) installed version 1.7 or above. Download the appropriate JDK for your operating system, run the installer, and then set up an environment variable called JAVA_HOME pointing to the location of this installation.
Tags: grails 3.0 jdk versão


0
Olá Fernando, essa é uma boa oportunidade prá testar a versão 8.

O pessoal tem elogiado muito esta versão.
16/04/2015 16:12


0
Estou testando mas no nosso servidor de produção ainda é 1.6, estamos estudando uma atualização para 1.8
16/04/2015 21:03


0
Eu tenho um cenário deste e funciona normalmente.
1 aplicação antiga no java7 e 4 aplicações no grails com java8.

Se estiver usando o tomcat, dentro do catalina.sh você consegue definir qual jdk usar, isso sem precisar alterar nada no sistema operacional.
Basta usar a instalação do JDK por ZIP.
17/04/2015 09:26



Ainda não faz parte da comunidade???

Para se registrar, clique aqui.


Aprenda Groovy e Grails com a Formação itexto!

Newsletter Semana Groovy

Assinar

Envie seu link!


Livro de Grails


/dev/All

Os melhores blogs de TI (e em português) em um único lugar!

 
Creative Commons
RSS Grails Brasil é mantido por itexto Consultoria.
Em caso de problemas contacte Henrique Lobo Weissmann (Kico) por e-mail: kico@itexto.com.br
Todo o conteúdo presente neste site adota o Creative Commons como licença padrão.
Ver: 4.14.0
itexto