Plugins no grails 3.x
04/04/2015 02:21
1
Estou tentando instalar o plugin ajax-tags e não consigo.

Os comandos install e create-plugin não funcionam conforme a documentação e dá erro se tento inserir no build.gradle, dentro de dependencies a linha:

compile "org.grails.plugins:ajax-tags"

porém se digito list-plugins ele lista e o ajax-tags está na lista bonitim...

esta novas versões do grails só estão me dando trabalho, primeiro tiraram a droga do remoteLink, poxa, tudo agora é organizado por div e os comandos remote direcionavam os render/response pra dentro das divs, sem muito trabalho, agora dá um trabalhão pra fazer a mesma coisa... depois a instalação automática de plugin por linha de comando, é como se tirassem o apt-get do linux... tudo bem que é configuração por convenção, mas esta versão 3.x nem um nem outro...
Tags: plugins, Grails 3.x


0
Oi Xnox,

na realidade, o comando install-plugin já era considerado obsoleto "deprecated" desde a versão 2.2 do Grails se não me engano.

De lá pra cá passaram a usar apenas a alteração do arquivo BuildConfig.groovy no Grails 2.x incluindo a dependência do plug-in no bloco plugins.

Já no caso do Grails 3.x, a instalação do plug-in muda apenas o nome do arquivo, que passa a ser, se não me engano, no arquivo build.gradle como uma dependência normal.

Com relação ao remoteLink, você está tendo esta dificuldade por que ele agora fica em um plug-in separado, e não faz mais parte do core do framework.

Minha sugestão com relação ao Grails 3.0, por enquanto, é esperar. Aguarde pela versão 3.0.4 ou 5 pelo menos para ter algo estável e usável. Até lá, uso apenas para fins exploratórios.


0
Oi, pois é, tenho uma aplicação que está rodando no 2.2.2 e de lá pra cá não consegui rodar mais com todas as funcionalidades devido ao uso intenso de javascript e ajax na parte do view...
Por incrível que pareça ela rodou quase sem modificação no 3.0, salvo a parte do ajax, tive apenas que ajustar o novo caminho:
<asset:stylesheet src="colorpicker.css"/>
Na documentação do 3.0, fala de um comando install para instalar plugins .jar local, mas nunca encontra o .jar mesmo no path.
Está mais lento que o 2.5, ainda precisa de muitos ajustes, mas promete :-)

Everton Sales
04/04/2015 17:22


0
Resolvido

Na verdade foi uma estupidez, coloquei um traço antes da versão e deve ser dois pontos, estas coisas de copiar e colar... aaarrrgggg...

o autor "Jeff Scott Brown - jeff@jeffandbetsy.net" recomendou rodar em tempo de execução, o que faz mais sentido:

runtime 'org.grails.plugins:ajax-tags:1.0.0.RC1'

Funcionou perfeitamente em meus testes preliminares.
04/04/2015 18:15


0
Estou brincando com o Grails 3.0 aqui neste momento. Curioso que uma das coisas que realmente gostei nele foi o fato da interface de linha de comando estar se comportando de uma maneira bem mais performática. :)


0
Pessoal bom dia,

Dando continuidade a este tópico de plugins no 3.x.  Eu tenho uma aplicação em versões anteriores com uma série de plugins e que não estão sendo encontrados no 3.x.  Podem me ajudar como ter os mesmos no 3.x ?   ( tentei declarar de muitas formas no build.gradle. )
Lista na versão antiga: 
?plugins.google-visualization
?plugins.rendering
?plugins.xfire
?plugins.asynchronous-mail
?plugins.excel-export
?plugins.joda-time
?plugins.remote-pagination
?plugins.zipped-resources

Obrigado e no aguardo
Pedro
02/06/2015 10:35



Ainda não faz parte da comunidade???

Para se registrar, clique aqui.


Aprenda Groovy e Grails com a Formação itexto!

Newsletter Semana Groovy

Assinar

Envie seu link!


Livro de Grails


/dev/All

Os melhores blogs de TI (e em português) em um único lugar!

 
Creative Commons
RSS Grails Brasil é mantido por itexto Consultoria.
Em caso de problemas contacte Henrique Lobo Weissmann (Kico) por e-mail: kico@itexto.com.br
Todo o conteúdo presente neste site adota o Creative Commons como licença padrão.
Ver: 4.14.0
itexto