Plugin br validations +Grails 2.4
27/10/2014 19:14
0
Pessoal, boa noite. Depois de algum tempo longe do GRails (por motivos de força maior) estou livre de novo para me dedicar aos estudos (terceira vez que tenho que interromper já) desse framework que me fisgou.

Hoje fazendo um teste de uso de algumas coisas que testei no passado, achei referência ao plugin BR Validations. Na página do plugin tem a documentação que segui a risca, mas na hora de rodar a App, se deu o seguinte:
|Loading Grails 2.4.3
Error |
There was an error loading the BuildConfig: Bad artifact coordinates :br-validation:0.3, expected format is <groupId>:<artifactId>[:<extension>[:<classifier>]]:<version> (Use --stacktrace to see the full trace)


Meu BuildConfig está assim:
dependencies {
// specify dependencies here under either 'build', 'compile', 'runtime', 'test' or 'provided' scopes e.g.
// runtime 'mysql:mysql-connector-java:5.1.29'
runtime ':br-validation:0.3'
runtime 'org.postgresql:postgresql:9.3-1101-jdbc41'
test "org.grails:grails-datastore-test-support:1.0-grails-2.4"
}


O que fazer se na doc simplesmente não tem o groupId pra inserir? Tem uma forma de usar sem ser declarando pelo BuildConfig?

PS: já mudei o scope pra compile também, mas isso não deveria ser problema e também não funcionou.
Tags: br validation, grails 2.4.3


0
Mal galera, tentando aqui achei o problema. Claro que não ia funcionar tendo em vista que estou tentando usar um plugin nas dependencies{} e não no plugins{}

Desculpem tomar vosso tempo :(
27/10/2014 19:17



Ainda não faz parte da comunidade???

Para se registrar, clique aqui.


Aprenda Groovy e Grails com a Formação itexto!

Newsletter Semana Groovy

Assinar

Envie seu link!


Livro de Grails


/dev/All

Os melhores blogs de TI (e em português) em um único lugar!

 
Creative Commons
RSS Grails Brasil é mantido por itexto Consultoria.
Em caso de problemas contacte Henrique Lobo Weissmann (Kico) por e-mail: kico@itexto.com.br
Todo o conteúdo presente neste site adota o Creative Commons como licença padrão.
Ver: 4.14.0
itexto