Upgrade 2.2.3 para 2.3.10
29/07/2014 16:32
0
Boa tarde,

Pessoal estou tentando migrar a versão do grails de 2.2.3 para 2.3.10 porem não estou obtendo sucesso.
Fiz como manda a documentação, olhei os releases, porem nada.
O projeto ainda roda porem toda vida que vou fazer uma requisição só obtenho o 404 como resposta.

Desde já grato.
Tags: Upgrade 2.2.3 para 2.3.10


0
Evaldo, se não me engano neste upgrade se faz necessário alterar o arquivo web.xml da aplicação caso você tenha instalado anteriormente os templates.

Outro ponto de atenção é o arquivo de configuração do Spring que também precisa ser alterado se você teve os templates instalados.

Infelizmente estou no meu celular agora, mas tendo acesso a um PC busco e te dou mais detalhes.


0
Obrigado Henrique.

Eu tenho os templates instalados sim. Porem já alterei o web.xml e nada, a unica alteração que eu fiz foi no version alterei pro 3.0 .
Tem algo a mais para alterar?


0
Oi Evaldo, tem sim.

Há alterações a serem feitas no arquivo applicationContext.xml. Dá uma lida neste link: http://grails.org/doc/latest/guide/upgradingFrom23.html



0
Henrique obrigado ae pelo link e por me ajudar.

Eu fiz as alterações dele porem não deu certo.
O sistema "roda", porem quando vou fazer uma requisição sempre retorna "404 Not Found".

O erro que aparece no console:

[DefaultMetadataResolver-10-1] WARN org.apache.http.client.protocol.ResponseProcessCookies - Cookie rejected: "[version: 0][name: rememberMe][value: deleteMe][domain: repository.jboss.com][path: /nexus][expiry: Fri Aug 08 17:54:52 BRT 2014]". Illegal path attribute "/nexus". Path of origin: "/maven2/org/atmosphere/atmosphere-project/1.1.0-SNAPSHOT/maven-metadata.xml".


0
Quais plugins você usa?


0
plugins {
build ':tomcat:7.0.52.1'

//runtime ':hibernate4:4.3.5.2'
// plugins for the build system only
// build ":tomcat:7.0.41"

// plugins for the compile step
// compile ":scaffolding:2.0.0.M1"
compile ":cache:1.1.7"
// compile ":atmosphere:0.4.2.1"
//runtime ":angularjs-resources:1.0.8"
// plugins needed at runtime but not for compilation
runtime ":hibernate:3.6.10.M4" // or ":hibernate4:4.1.11.M1"
runtime ':database-migration:1.4.0'

runtime ':jquery:1.11.0.2'

runtime ":resources:1.2.RC2"

compile ":rest:0.7"
compile ":rest-client-builder:1.0.3"
compile ":aws-sdk:1.7.7"

compile ":export:1.5"
/* Parei aqui, tem que atualizar o spring.*/
compile ":spring-security-core:2.0-RC3"
compile ":spring-security-rest:1.4.0.RC5", {
excludes: 'spring-security-core'
}

compile ":elasticsearch-gorm:0.0.2.3"

compile ":mail-on-exception:0.1.1"

compile ":remote-pagination:0.4.4"

compile ":jasper:1.8.0"

// Uncomment these (or add new ones) to enable additional resources capabilities
runtime ":zipped-resources:1.0.1"
// runtime ":cached-resources:1.1"

runtime ":yui-minify-resources:0.1.5"

runtime(':mail:1.0.6') {
transitive = false
}
compile ":quartz:1.0.1"

compile ":asynchronous-mail:1.0-RC5"

compile ":events-push:1.0.M7"

}


0
Bom dia!

Pessoal estou com o mesmo problema citado acima...Alguma novidade que possa nos ajudar?



Obrigado.
12/08/2014 10:23


0
Postei no twitter do Grails Brasil. Há mais algum detalhe que possa ser passado aqui?


0
Descobri que o erro é relativo ao ":events-push:1.0.M7", quando eu adiciono ele na lista de plugins a aplicação simplesmente para de funcionar, mesmo apos tira-lo e dar um "clean" e "refresh" a aplicação não funciona.

Obrigado.


0
Plugins, sempre aprontando das deles.

Removendo o plugin o problema é resolvido Evaldo?


0
Ae que está o problema o plugin roda perfeitamente no grails 2.2.3, porem no 2.3.11 ai instalar o plugin a aplicação simplesmente "morre".
Mesmo apos retirar o plugin a aplicação não funciona.


0
Uai Evaldo, então o problema não é o plugin, não?

Postei o seu problema no Twitter pela minha conta também para ver se alguém enfrenta situação similar. Assim a gente se une e aprende a resolver esta questão, ok?

Enquanto isto, minha sugestão é você manter a versão corrente do Grails mesmo. Você realmente tem um grande que compense o upgrade?


0
Opa Henrique obrigado pela ajuda, já to a quatro dias tentando resolver isso.

Sim o upgrade é necessário, preciso inserir o plugin "spring-security-rest" e ele só funciona com grails > 2.3.x .

Henrique eu andei estudando e analisando o problema, não consigo instalar o plugin "atmosphere" no grails 2.3.x (no caso estou utilizando a 2.3.11), basta instalar esse plugin que a aplicação para de funcionar.

Obrigado.


0
Henrique descobri o problema.

O plugin atmosphere não funciona com o tomcat > 7.0.50.

De toda forma para quem tiver a mesma duvida segue o link com mais detalhes : https://github.com/kensiprell/grails-atmosphere-meteor/issues/32

Obrigado.



Ainda não faz parte da comunidade???

Para se registrar, clique aqui.


Aprenda Groovy e Grails com a Formação itexto!

Newsletter Semana Groovy

Assinar

Envie seu link!


Livro de Grails


/dev/All

Os melhores blogs de TI (e em português) em um único lugar!

 
Creative Commons
RSS Grails Brasil é mantido por itexto Consultoria.
Em caso de problemas contacte Henrique Lobo Weissmann (Kico) por e-mail: kico@itexto.com.br
Todo o conteúdo presente neste site adota o Creative Commons como licença padrão.
Ver: 4.14.0
itexto