Erro quando compilando projeto com plugin audit-logging-0.5.3
22/08/2011 11:36
0
Bom dia pessoal.

Estou com um problema de upgrade, pois atualizei a minha aplicação da versão grails 1.2 para a versão grails 1.3.7, contudo estou pegando um erro quando tento compilar a aplicação depois de aplicar o comando clean.

Acontece que eu uso o plugin audit-logging-0.5.3 e na versão grails 1.2 não tinha nenhum problema quando eu dava um import em um pacote da minha aplicação para manipular algo, portanto, o problema é: dentro do plugin não consigo mais enxergar mais as minhas classes de service, domain e controller e quando tento compilar pego o erro:

[C:\Users\Stefano.WJDOMAIN\.grails\1.3.7\projects\AAF2.51\plugins\audit-logging-0.5.3\src\groovy\org\codehaus\groovy\grails\plugins\orm\auditable\AuditLogListener.groovy: 508: unable to
resolve class GerenciadorOffline
@ line 508, column 24.
GerenciadorOffline genOffline = null]

Existe alguma configuração na versão grails 1.3.7 ou tenho que indicar no path alguma coisa?

Lembrando que na versão 1.2 não existia qualquer configuração extra de ambiente para da import dentro plugin, ou seja, ele reconhecia automaticamente todos os meus pacotes.

Agradeço a atenção de vocês.
Tags: Upgrade grails 1.3.7


0
No site do plugin (http://www.grails.org/plugin/audit-logging) encontrei o seguinte trecho:

"Users of Grails 1.2.x and below should use version 0.5.3 of this plugin. Users of Grails 1.3.x and above should use version 0.5.4 (or greater) of this plugin."



Ainda não faz parte da comunidade???

Para se registrar, clique aqui.


Aprenda Groovy e Grails com a Formação itexto!

Newsletter Semana Groovy

Assinar

Envie seu link!


Livro de Grails


/dev/All

Os melhores blogs de TI (e em português) em um único lugar!

 
Creative Commons
RSS Grails Brasil é mantido por itexto Consultoria.
Em caso de problemas contacte Henrique Lobo Weissmann (Kico) por e-mail: kico@itexto.com.br
Todo o conteúdo presente neste site adota o Creative Commons como licença padrão.
Ver: 4.14.0
itexto